TortoiseSVN, AnkhSvn a 'Client too old to work with working copy' error

MyEgo.cz

home foto blogy mywindows.cz kontakt

TortoiseSVN, AnkhSvn a 'Client too old to work with working copy' error

Tip dne 07.05.09

Pokud používáte AnkhSvn pro prodporu Subversion ve Visual Studiu a zároveň TortoiseSvn mohli jste se dostat do problému, zvláště pokud se snažíte updatovat příliš často.

Daná situace nastane, když provedete Checkout v TortoiseSvn a pak ve VS nemůžete provést v podstatě jakoukoliv operaci, jelikož se pokaždé objeví chybová hláška 'Client too old to work with working copy'.

Příčinou je rozdíl verzí podporovaných v TortoiseSvn a AnkhSvn. Momentální verze AnkhSvn podporuje Subversion verzi 1.5, kdežto novější verze TortoiseSvn podporují již verzi 1.6.

Aktuálním řešením je udělat downgrade TortoiseSvn na verzi 1.5.9, která stále podporuje Subversion verzi 1.5. Až AnkhSvn bude podporovat Subversion v1.6, tak můžete udělat upgrade i u TortoiseSvn.

A jaké jest ponaučení? Nedělat slepě upgrade, jenom proto, že je dostupný. Zvláště zbystřit, když jde o upgrade s větší důležitostí. (Major, Minor upgrade).


Nový komentář

Pro přidání komentáře se musíte nejdříve  registrovat Facebookem

Banan.cz